Activation Email Link after registration not being sent

This topic contains 11 replies, has 2 voices, and was last updated by  Guust 3 weeks, 1 day ago.

  • Author
    Posts
  • #5321

    mb299
    Buyer
    Post count: 84

    Hello,

    I am using WP Ver :5.2.3 & GD Ver :2.0.0.66

    Its a listing website using Supreme Directory theme. The plugins that i am using are Geo Directory, Ninja Forms, Code Snippets and USERSWP.

    Was trying to look for similar topics on :Activation Email after Registration” but couldn’t find anything substantial, hence New Topic.

    I registered myself as a new user and didn’t get the link in my email to activate the account. Then i used the “Resend Activation Mail” link but no mail still. No mail in my SPAM folder as well.

    I tried to Login with my credentials and get a message that “Your account is not activated yet. Please check your email for activation email”.
    Need your help please.

    Thanks /Manish

    #5322

    mb299
    Buyer
    Post count: 84

    Adding a Screenshot too which says that the mail has been sent & shows that the Subscriber is approved too. Whereas, in reality, no email & can’t login.

    Attachments:
    You must be logged in to view attached files.
    #5324

    Guust
    Moderator
    Post count: 27891

    Please install the Email Log plugin.
    That will log all emails sent. If that shows the email is prepared and sent, then the issue is with your host or the recipient.
    Make sure that users check their spam box.

    Thanks

    #5325

    mb299
    Buyer
    Post count: 84

    Thanks Guust, Will install this plugin.

    But here’s a quick update – I got the activation email after 2 hours of registering(just now). Do you think i should take this up with my hosting company?

    Manish

    #5328

    Guust
    Moderator
    Post count: 27891

    It could also be your email provider, or your email program settings.
    Thanks

    #5336

    mb299
    Buyer
    Post count: 84

    Hi Guust,

    I checked with my hosting company & rectified things. They suggested to configure WP SMTP Mail configuration plugin.

    Now:

    1. The activation email is being sent immediately to a gmail account but not to the Hotmail account. Any idea why not hotmail?
    2. After clicking on the activate link in the email, it takes me to the Login page, which says ” Account activated successfully. Please login” -(After registration redirect page is set to Login page)
    3. After providing the credentials on login page, it says “You account is not activated yet. Please check your email for activation email” – (After Login redirect page is set to Last User page)

    Please suggest

    Manish

    #5337

    Guust
    Moderator
    Post count: 27891

    1. The activation email is being sent immediately to a gmail account but not to the Hotmail account. Any idea why not hotmail?

    Make sure the emails are sent from the same domain as the website, and edit the email content to make it specific to your site.
    Make sure that your email host has all the correct SPF, DKIM, and DMARC set up. Thoses are the three established methods used to verify a sender’s identity. Your host should be able to help with that.

    2. After clicking on the activate link in the email, it takes me to the Login page, which says ” Account activated successfully. Please login” -(After registration redirect page is set to Login page)

    Redirect after registration only works if you do not require activation. “After registration redirect page is set to Login page” is not the same as “After activation redirect page is set to Login page”.

    3. After providing the credentials on login page, it says “You account is not activated yet. Please check your email for activation email” – (After Login redirect page is set to Last User page)

    Can you post your URL and WP admin details in a private reply if we need to have a look at that. That is not normal.

    Thanks

    #5338

    Guust
    Moderator
    Post count: 27891

    I suggest you test point 3 after de-activating your caching plugin to see if that is the reason.
    https://wpgeodirectory.com/docs-v2/faq/performance/#cache

    #5339

    mb299
    Buyer
    Post count: 84

    Thanks Guust,

    Point 1: Sorted

    Point 2: Please suggest what pages to redirect to after
    a. Registration
    b. Login

    Point 3: I am using A2 Fixed W3 Total Cache & just deactivated. It worked & i could login with my credentials.

    But now , should I keep it de-activaed? What should be the approach. Please suggest.
    Manish

    #5340

    Guust
    Moderator
    Post count: 27891

    You cannot redirect after activation.
    After login, most people used “last viewed page”, so when they login they go back where they were.

    We recommend WP Super Cache: https://wpgeodirectory.com/docs-v2/faq/performance/#recommended-cache-plugin

    Thanks

    #5341

    mb299
    Buyer
    Post count: 84

    Thank you Guust for helping me out, as always

    Regards /Manish

    #5345

    Guust
    Moderator
    Post count: 27891

    You’re welcome

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.