Google auth fails with the message "Couldn't fetch the email address of a user..

This topic contains 9 replies, has 3 voices, and was last updated by  Patrik 1 year, 5 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #8109
    #8115

    Alex Rollin
    Moderator
    Post count: 27815

    You are granting permission when you register?
    Steps:
    1. Go to https://console.developers.google.com
    2. You will see dropdown after Google APIs logo click on it and then click Create Project link on the top right corner of the popup.
    3. Fill in the details for the new project and click on create.
    4. Again go to projects dropdown and select the project you created recently.
    5. Click on ENABLE APIS AND SERVICES button and search for Google+ API and click on the enable button to enable that API.
    6. After enabling click on the OAuth consent screen on the left sidebar menu and fill up all the details. Don’t forget to enter your site URL into the Authorized domains.
    7. After that you will need to create credentials. Go to credentials on left sidebar menu. Click on Create credentials button and select OAuth client ID.
    8. Choose Web application from the list and fill all the details. Enter the URL from the UsersWP google social login settings to the Authorized redirect URIs field and click on create.
    9. You will get your Client ID and Client Secret in the popup. Enter those into our UWP google social login settings and you are done.

    If that doesn’t work please send a screenshot of the error.

    #8120

    compradesdecasa
    Free User
    Post count: 7

    I’ve started over, created a new project, new credentials. And I still get this result.

    The redirected URL is this one:
    https://devel.compradesdecasa.cat/?action=uwp_social_authenticated&provider=google

    And I attach the error screen.

    #8171

    Patrik
    Moderator
    Post count: 1971

    Hi,

    This error displays when there is no email address returned by google social login. Make sure you have selected for email access while creating an app.

    Regards,
    Patrik

    #8172

    compradesdecasa
    Free User
    Post count: 7

    Sorry, I can’t figure whre should I select an email address when creating the app. When you login in you developer console to create the app and credentials, you use your google email address.

    And when you try to login via social you are asked for permissions and grant them.

    But then I get this message, Facebook login works flawlessly.

    #8178

    Patrik
    Moderator
    Post count: 1971
    This reply has been marked as private.
    #8179

    compradesdecasa
    Free User
    Post count: 7
    This reply has been marked as private.
    #8180

    Patrik
    Moderator
    Post count: 1971
    This reply has been marked as private.
    #8181

    compradesdecasa
    Free User
    Post count: 7
    This reply has been marked as private.
    #8182

    Patrik
    Moderator
    Post count: 1971

    Hi,

    I think the app is not properly configured or created. See attached screenshot where the app is not asking for the email address. So if you can recreate the app and check if it works for you or not. Also, your app should be verified by google. You can search for it in google how you can verify the app.

    Regards,
    Patrik

Viewing 10 posts - 1 through 10 (of 10 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket