Register redirect and "invalid user/password" on registration

This topic contains 18 replies, has 3 voices, and was last updated by  patrik 3 months ago.

  • Author
    Posts
  • #3915

    Tim Sanford
    Free User
    Post count: 120

    Hi there,
    Encountered a series of issues I hope you could help me with.

    Earlier today, I noticed that when a user registers, they are not redirected to the specified page(account) per the backend settings on registration redirect. Also fwiw, the S2 custom registration options are not enabled.

    I started doing some testing to see why this may now be the case, in doing so, whenever I create a now user account now, I get the following error “Error: Invalid username or Password.”

    I’d like to also note that the user account is created, but it presents the screen attached.

    Please advise

    Attachments:
    You must be logged in to view attached files.
    #3918

    Alex Rollin
    Moderator
    Post count: 19654

    Hello,

    please share the URL so we can see the issue, and also share WP Admin in a private reply so we can check the settings.

    Thanks

    #3919

    Tim Sanford
    Free User
    Post count: 120
    This reply has been marked as private.
    #3920

    patrik
    Moderator
    Post count: 1268
    This reply has been marked as private.
    #3958

    Tim Sanford
    Free User
    Post count: 120

    Hi again, so the latter part of the issue is no longer present(which is good). However the post-register redirect is not working 🙁

    I’ve attached screens of the flow if that helps(userReg1,2,3) and a screenshot of the current settings(userRegOptions):

    starting point> https://perfectpaddles.com/membership/

    Attachments:
    You must be logged in to view attached files.
    #3967

    Tim Sanford
    Free User
    Post count: 120
    This reply has been marked as private.
    #3980

    patrik
    Moderator
    Post count: 1268

    Hi,

    It seems there is a conflict with either any other plugin or theme. I have tried to change the redirect URL using the filter provided by UWP but still not working. So I would suggest you create a staging site with the default theme and UsersWP plugin only and if still, the issue is there then let us know and we will troubleshoot it.

    Regards,
    Patrik

    #4073

    Tim Sanford
    Free User
    Post count: 120

    Hi, I’m not sure exactly how to test on a staging site. Accessing it requires logging in which would not be possible for a test user that is not yet registered. I don’t see a setting to adjust this or allow general access in “wp-staging”(unless I’m overlooking it)

    Might the best path be take down the site temporarily for “scheduled maintenance”?

    #4090

    Alex Rollin
    Moderator
    Post count: 19654

    Hi,

    Those are restrictions of your hosting provider?
    Can you duplicate the site to another location for testing?
    A

    #4110

    Tim Sanford
    Free User
    Post count: 120

    I have a couple things to report back;

    1) The error I mentioned above in #3915 has re-presented itself

    I started doing some testing to see why this may now be the case, in doing so, whenever I create a now user account now, I get the following error “Error: Invalid username or Password.”

    Tested against 3 browsers and was present on each; chrome, firefox, edge

    2) After some testing, S2 member is in fact the cause of the conflict for the on-register redirect

    #4113

    Tim Sanford
    Free User
    Post count: 120

    In fact, when any user goes to login they get the error message

    Error: Invalid username or Password.

    #4114

    Tim Sanford
    Free User
    Post count: 120

    Another update: Contacted hosting support – had them clear the server cache and that resolved the

    Error: Invalid username or Password.

    This leaves us the with S2Member resulting in the post registration redirect conflict

    #4116

    patrik
    Moderator
    Post count: 1268

    So you mean the invalid username or password error was due to server cache and the registration redirect is due to S2Members plugin? There can be settings in S2Members plugin to prevent register redirect and leave it on UsersWP to handle it.

    Regards,
    Patrik

    #4120

    Tim Sanford
    Free User
    Post count: 120

    Yes, it seems the invalid username/PW error was a result of server caching.

    What exactly do you mean by the end of this sentence

    There can be settings in S2Members plugin to prevent register redirect and leave it on UsersWP to handle it.

    What do you recommend as next steps?
    And thanks for your time through this

    #4129

    patrik
    Moderator
    Post count: 1268

    Hi,

    I have tried to use different hooks and filters from UWP and S2members plugins but still not able to find a solution for registration redirection to home. I would suggest you deactivate other plugins and check after activating one by one to find which plugin creates problems.

    Regards,
    Patrik

Viewing 15 posts - 1 through 15 (of 19 total)

The topic ‘Register redirect and "invalid user/password" on registration’ is closed to new replies, this may be for inactivity, please open a new topic if you have a similar question.