Update crashed site

This topic contains 16 replies, has 4 voices, and was last updated by  Stiofan O’Connor 2 years, 12 months ago.

  • Author
    Posts
  • #503

    Steve
    Expired Member
    Post count: 1019

    I have revered back to the pre-update of today to the prior version.

    I received the following error message after updating with latest update:

    “This is the error message.

    Fatal error: require_once(): Failed opening required ‘/home/cannabispeeps17/public_html/wp-content/plugins/userswp/includes/class-users-wp.php’ (include_path=’.:/opt/cpanel/ea-php56/root/usr/share/pear’) in /home/cannabispeeps17/public_html/wp-content/plugins/userswp/userswp.php on line 71

    I am going to revert back to previous version.

    #504

    Guust
    Moderator
    Post count: 29970

    Which plugin exactly did you update? WPusers only?

    Please post URL and WP admin details in a private reply.
    We may also need FTP.

    #505

    Steve
    Expired Member
    Post count: 1019

    This is the one. As I view this in the admin seciton.. (this time I will not update)

    “There is a new version of UsersWP available. View version 1.0.7 details or update now.”

    Attachments:
    You must be logged in to view attached files.
    #509

    Giri
    Expired Member
    Post count: 3155

    Hi Steve,

    1.0.7 doesn’t contain the file you mentioned in your error.

    https://plugins.trac.wordpress.org/browser/userswp/tags/1.0.7/userswp.php#L72

    Not sure whats going on. I’ll discuss with stiofan and let you know.

    Thanks

    #510

    Giri
    Expired Member
    Post count: 3155

    Hi Steve, can you post your wp-admin and ftp details?

    Thanks

    #512

    Steve
    Expired Member
    Post count: 1019
    This reply has been marked as private.
    #513

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    We need ftp too.

    Stiofan

    #515

    Steve
    Expired Member
    Post count: 1019
    This reply has been marked as private.
    #517

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Hi Steve,

    Your server is using opcache to cache php files but its not clearing the cache right, i think its probably a server setting problem with opcache.use_cwd being set to 0

    I have added a file that will clear the cache, if u see the problem in future just visit this file to clear the cache: https://cannabispeeps.com/flush_cache.php (it will just be a blank page)

    Thanks,

    Stiofan

    #518

    Steve
    Expired Member
    Post count: 1019

    Thank you Stiofan. I appreciate the support.

    Do you have a suggestion on what the opcache.use_cwd setting should be? If, yes, I will have the setting s changed.

    Thank you,

    Steve

    #519

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Its a binary setting, 1 or 0, i suggest it should be 1 🙂

    Stiofan

    #520

    Steve
    Expired Member
    Post count: 1019

    Thank you once again. I will call this in now and also keep an eye on the site.

    Kind regards,

    Much appreciated.

    Steve

    #522

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Np, they might tell you they set it to 0 for speed which is true but if you have updates then it can break things, even a WP auto update and you would need to run that file i added.

    Thanks,

    Stiofan

    #523

    Steve
    Expired Member
    Post count: 1019

    Update Stiofan. They have change the settings and will restart apache server and another service. If there are not problems after that, we are good to go.

    Thank you.

    Steve

    #524

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Great! 🙂

Viewing 15 posts - 1 through 15 (of 17 total)

The topic ‘Update crashed site’ is closed to new replies, this may be for inactivity, please open a new topic if you have a similar question.