Users can log in

This topic contains 26 replies, has 3 voices, and was last updated by  Dotty Directory 3 days, 16 hours ago.

  • Author
    Posts
  • #3830

    Dotty Directory
    Buyer
    Post count: 247

    Had a few reports that users cant log in, both before and after changing their password.

    I’ve actually experienced the same issue, I can log in via desktop, but not on my mobile.

    It’s a new built website, with V2 Dotty Directory on, using WP Super Cache, Autoptimize and Cloudflare VPN, I have set a page rule on the login page (as well as profile page and add-listing page) that sets cache level to “Bypass”.

    I’ve installed a little plugin called “Busted” aswell which is supposed to clear the users cache.

    I genuinely can’t figure out what could be causing the issues, would it be ok to have a quick look for me?

    FTP and Login details to follow.

    #3831

    Dotty Directory
    Buyer
    Post count: 247
    This reply has been marked as private.
    #3832

    Dotty Directory
    Buyer
    Post count: 247

    Just realised the title was mean’t to be “Users can’t log in”

    #3837

    Alex Rollin
    Moderator
    Post count: 15184

    Thanks for reporting. Is there an error? What happens when you can’t login?

    #3839

    Dotty Directory
    Buyer
    Post count: 247

    Hi Alex, it just says incorrect username / password. I thought it might of been the recaptcha so I disabled it. Still the same, unfortunately I tried alot to see if there was a conflict, disabled all plugins, theme, even rolled back. But to no avail.

    #3841

    patrik
    Moderator
    Post count: 891

    Hi,

    Can you check? It is not allowing me to login into admin as well as on frontend. It is giving access denied error. See attached screenshot.

    Attachments:
    You must be logged in to view attached files.
    #3844

    Dotty Directory
    Buyer
    Post count: 247

    Apologies, that is down to cloudflare I had it in development mode it must of turned back on.

    It should be ok now

    #3845

    patrik
    Moderator
    Post count: 891

    Hi,

    I have registered a new user and logged in via login form and it worked properly. I think there might be issues due to caching. So you will need to remove/exclude the caching for UsersWP login and register pages and then check if it works for you or not.

    Let me know if you still find the issues and we are here to help you!

    Regards,
    Patrik

    #3846

    Dotty Directory
    Buyer
    Post count: 247

    Hi Patrik, thanks for taking a look. Currently caching is completely off on the site itself, the plugin is WP Super Cache.

    Cloudflare is the only other thing caching but I’ve already excluded it using a page rule. I’ve attached a screenshot.

    Is there something else that could be causing it?

    I’ve attached a full system report if that will help (generated by GeoDirectory)

    Thanks, Mark

    Attachments:
    You must be logged in to view attached files.
    #3849

    patrik
    Moderator
    Post count: 891

    Hi,

    I have tried with another user and both registration and login forms are working. So it may be possible after deactivating the cache it works fine. If you are still facing an issue then let me know the username and password and also share small video to regenerate the issue so that I can troubleshoot it and fix it.

    Regards,
    Patrik

    #3850

    Dotty Directory
    Buyer
    Post count: 247
    This reply has been marked as private.
    #3851

    patrik
    Moderator
    Post count: 891

    Can you please check after clearing cache in your mobile?

    I have checked the same in my mobile and worked fine but I had never opened this site before so no cache stored. I have attached a screenshot for your reference.

    Regards,
    Patrik

    Attachments:
    You must be logged in to view attached files.
    #3853

    Dotty Directory
    Buyer
    Post count: 247

    Unfortunately, I’ve cleared the cache and it’s still present.

    There’s nothing in particular that I can see that’s causing it, it’s a bit of a random error with nothing particular in common between cases

    #3854

    patrik
    Moderator
    Post count: 891

    I would suggest you check the same with other people around you and if it is not working fine then create a staging server and provide me the admin and FTP credentials where I can do troubleshoot without affecting your live users. I will need to check by deactivating few plugins and may switch theme to default for troubleshooting.

    Regards,
    Patrik

    #3866

    Dotty Directory
    Buyer
    Post count: 247

    Setting up a staging site now Patrik, will let you know when it’s ready. Many thanks for looking into this for me.

    Best,
    Mark

Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.